Resolved
AWS Outage

Started
December 15, 2021 at 3:44 PM
Status
Resolved after 29 minutes

Impact

Major outage
Affected
Printer Service
Retailer Dashboard
eCommerce Applications
Service Providers
AWS
  • Resolved
    December 15, 2021 at 4:13 PM

    AWS has resolved the issue - we will continue to monitor throughout the day to ensure all systems are operational.

  • Update
    December 15, 2021 at 4:06 PM

    Our infrastructure hosting provider, Amazon, has experienced a major outage.

    The Amazon AWS US-WEST-2 Region internet connectivity outage is slowly recovering.

    Store sites & dashboards should start to work shortly but may experience slowness as Amazon recovers from the issue.

  • Monitoring
    December 15, 2021 at 3:44 PM

    There is currently an Amazon Web Services outage that is affecting online stores & dashboards - we're currently investigating and actively working to mitigate the issue.